An optimized method to quantify large numbers of amphibian eggs

Article in Herpetology Notes · October 2017

2 authors:

Jason Bohenek
University of Mississippi
3 PUBLICATIONS 4 CITATIONS

William J Resetarits
University of Mississippi
59 PUBLICATIONS 2,414 CITATIONS

Some of the authors of this publication are also working on these related projects:

Project
An optimized method to quantify large numbers of amphibian eggs

All content following this page was uploaded by Jason Bohenek on 20 October 2017.

The user has requested enhancement of the downloaded file.
An optimized method to quantify large numbers of amphibian eggs

Jason R. Bohenek1,* and William J. Resetarits, Jr.1

Abstract. We developed a fast and cost-efficient method to quantify large numbers of amphibian eggs employing freely available software. With a large copy stand, bent glass dish, and tracing light pad, we photographed amphibian eggs for automated quantification using ImageJ and compared those counts to hand counts. Our automated method had high agreement with hand counts ($R^2 = 0.999$), but dramatically accelerated average processing times from 317 seconds to 35 seconds. Automated counts had high time efficiency and low error when clutch sizes were greater than 90 eggs. Overall, this method greatly facilitates counting eggs in amphibian clutches and represents a key innovation for those requiring quantitative data for studies of amphibian reproduction.

Keywords: Oviposition, indirect counts, Hyla, ImageJ, image processing, clutch size.

Introduction

One of the primary costs accrued during biological research is personnel wages. Therefore, improving research efficiency by reducing time spent on repetitive, tedious tasks is a conscientious exercise in cost management that should be favoured by anyone needing to expand the number of tasks that can be accomplished with limited funding. Counting is one such simple, repetitive, and time-consuming task. While computers and digital photography have become ubiquitous tools (e.g., Hand, 2012; Frauenfelder, 2013) that can dramatically decrease the duration of a counting task, not all aspects of counting in biology have received the benefit of a computer- and photography-based algorithm. We developed a fast, efficient, and reliable method to count large numbers of amphibian eggs that is broadly applicable when counting any type of small particle, including eggs, seeds, or pollen grains, is required.

Treefrogs (genus Hyla) oviposit in various freshwater habitats, including aquatic mesocosms, in which they so persistently breed that the placement of window screen lids may be necessary specifically to keep them out (Morin, 1981). Treefrogs are also valuable model organisms for examining how species distributions are affected by different biotic and abiotic factors. For example, predator presence has a strong effect on anuran oviposition site choice (Resetarits and Wilbur, 1989). Likewise, pesticides (Takahashi, 2007; Vonosh and Buck, 2007) and canopy cover (Binckley and Resetarits, 2007) deter oviposition behaviour, and spatial contagion causes these patch effects to bleed over into adjacent patches (Resetarits, 2005). Quantifying treefrog eggs was a necessary component of these studies, and this process has gone through a number of methodological changes over the decades.

To provide a historical perspective, eggs were initially counted by hand when samples were small. For larger egg numbers, an apparatus consisting of a 35-mm SLR camera, a light stand, the Polachrome 35-mm Instant Slide System, a photo enlarger, a digital pen counter (Bel-Art Products, Wayne, New Jersey, USA; www.belart.com), and a fixed sampling grid (Resetarits and Wilbur, 1989) was assembled. Using this setup, eggs from a given mesocosm were collected into individually labelled 14.2-litre plastic containers, transported to the lab, spread into a uniform monolayer, photographed using a camera mounted to the light stand, immediately developed to check for clarity, mounted in individual slide mounts, taken to the darkroom, projected precisely onto a photocopy of the sampling grid using a photo enlarger, and counted within the fixed grid cells using
the digital pen. The largest samples from individual mesocosms often required several photographs. The photographic approach was necessitated by the need to quickly document oviposition responses and return the eggs to rearing tanks within 8 h of collection to be ready for the next day’s sampling. The grid approach was an early attempt to expedite counting since a large number of eggs (ca. 145,000) needed to be quantified by a single researcher. This approach produced counts that deviated by 7% from the actual hand counts on ten test photos (Resetarits and Wilbur, 1989). The grid approach was retired as later studies (e.g., Binckley and Resetarits, 2003; Resetarits, 2005) used a similar approach employing digital cameras, which allowed photos to be printed immediately and counted using a digital counting pen.

**Materials and Methods**

Eggs were collected from mesocosms, which are composed of use loose-fitting, partly submerged fibreglass screen lids fastened onto large cattle tanks (Fig. 1) or wading pools. Lids prevent eggs from sinking into the leaf litter, facilitate clean collecting, and prevent egg predation if experiments involve predator treatments. Once the mesocosm array is constructed and the pools are “opened” by pushing screens into the water (Fig. 1), they are checked daily for frog eggs, which are collected and returned to the lab. To make processing easier, eggs are collected with minimal water and cleaned of debris (leaves, dead insects, etc.). Amphibian egg clutches often range from hundreds to thousands of eggs, and since amphibian eggs are relatively large and easy to see with the naked eye, many researchers have simply employed tedious hand counting (e.g., Kats and Sih, 1992; Takahashi, 2007), relied on estimates (Resetarits and Wilbur, 1989; Kats and Sih, 1992), or avoided counting individual eggs entirely (Petranka et al., 1994; Kapust et al., 2012; Xu and Li, 2013; Lind et al., 2016), and thereby possibly lost data resolution. By coupling an optimized studio setup (Fig. 2) with automated ImageJ processing (Fig. 3), we developed a method to quickly produce ideal photographs that provide accurate results for large volumes and high quantities of amphibian eggs.

A large studio copy stand (Fig. 2A) (60 × 60 × 107 cm) was used to vertically mount our camera (Fig. 2B) directly above our egg sample. Eggs were placed in a large, circular, clear glass dish with flat base and no lip (Fig. 2C). The specific dish we used had an upper diameter of 40.6 cm with a 30.5-cm base diameter at 2 cm depth (Behrenberg Glass, Delmont, Pennsylvania, USA; www.behrenbergglass.com). Using a dish of this shape helps reduce shadow and reflection artefacts in the image. The sample dish was placed on a large (43.2 cm × 43.2 cm × 12.7 cm) light pad.
Lightmaster tracing light pad (Fig. 2D) (US Art Supply, San Diego, California, USA; www.usartsupply.com) and was positioned on the studio copy stand centred beneath the camera. Photos were taken with a high-resolution digital camera (body: Nikon D3300; lens: 18–55mm F3.5–5.6 VR II; resolution: 24 megapixels). Our camera was positioned 41 cm vertically above the sample with a focal length of 24 mm. External lamps or camera flashes are unnecessary because the light pad provides optimal contrast for processing (Fig. 3).

We compared the automated ImageJ approach (Appendix) to hand counting for 26 samples (n = 26) collected from 27 July–9 August 2016 at the University of Mississippi Field Station (34.4275°N, 89.3881°W). ImageJ is an open-source image-processing program (requires Java 1.5 or later) from the National Institutes of Health (Rasband, 1997) that has been used to quantify cell cultures (Cai et al., 2011) as well as small numbers of fish (Duan et al., 2015) and mosquito eggs (Mains et al., 2008). To hand count, we used a hand tally counter to visually count multiple subsamples that were combined. Like our automated count, each hand count was timed and completed once all eggs of a sample were tallied. Percent error was used to evaluate the accuracy of the automated method and use hand counts as theoretical values. Percent error was calculated as (automated count – hand count) / hand count × 100. Student’s t-test was used to compare time of hands counts against time of automated counts. Linear regression was used to evaluate the agreement between hand counts and automated counts, the relationship between hand counts and percent error, and the relationship between hand counts and efficiency. All analyses set α = 0.05 and used R v 3.4.0 (R Core Team, 2017).

Results

The automated ImageJ method (mean 35.86 s ± standard error 0.96) was substantially faster and more efficient than hand counting (316.62 s ± 59.34; t 25.012 = 4.765, P < 0.001; Fig. 4A). When fitting a simple linear model, we found high agreement between automated and hand counts but automated counts were significantly faster (F 1,24 = 2.379 × 104, P < 0.0001, R² = 0.999; Fig. 4B). The error of the automated method decreased as hand counts increased (F 1,24 = 5.471, P = 0.0280, R² = 0.152; Fig. 4C). Efficiency improvement (hand count time/automated ImageJ time) of the automated method dramatically increased with higher hand counts (F 1,24 = 235.4, P < 0.0001, R² = 0.904; Fig. 4D); however, efficiency was < 100% when counts were < 90 eggs.

Discussion

The automated ImageJ method was accurate, faster and more efficient than hand counts, especially with larger clutches. However, the automated ImageJ method for counts < 90 had higher error and was less efficient (Fig. 4C, D), so we suggest hand counting of samples < 100 eggs. Since hylid clutch sizes and those of many other anurans are typically much greater than 100 eggs, reliance on hand counting will be minimal. Additionally, this 100-egg threshold may vary interspecifically as egg clutch sizes vary and may change counting efficiency.

The automated ImageJ method also allows improved organization and archiving by creating records in digital image form.

Figure 3. (A) Unprocessed photograph of Hyla chrysoscelis (Cope, 1880) eggs using light pad background and glass dish. (B) The same photograph with applied processing for the automated ImageJ method.
Debris can be a significant source of error for automated ImageJ counts, but not necessarily for hand counts. The effect of debris on error is greater the closer in size the debris is to target egg size. Thus, we highly suggest cleaning samples before taking photographs, which adds additional time to automated ImageJ counts. It is not always necessary to clean debris when hand counting, thus lessening the difference between methods when samples have debris. However, this difference only matters when counts are small as automated ImageJ counts are exceedingly more efficient as counts increase. Also, high volume samples (i.e., those that may contain superfluous water or a multitude of eggs) may require more than one photograph, which can also decrease the efficiency of automated ImageJ counts. We advise creating a proper studio setup to eliminate the need for additional photos. Furthermore, this method may not work for all species, especially those that lay globular egg masses that are difficult to disperse into a monolayer (as found in ranid frogs, ambystomatid salamanders, and others). However, if a model species meets these requirements, our method will dramatically reduce effort and simultaneously improve accuracy.

**Acknowledgements.** We would like to thank the Henry L. and Grace Doherty Foundation and the University of Mississippi for funding, and the University of Mississippi Field Station for facilities and natural environments. Also, thanks to Brandon McDaniel, Zachary Mitchell, and Tyler Breech. This research was approved by the University of Mississippi’s Institutional Animal Care and Use Committee (14-027), the Mississippi Department of Wildlife, Fisheries, and Parks (0624141) and conformed to all state and federal regulations.

**Figure 4.** Graphic representations of speed and accuracy of the automated counting method for amphibian eggs. (A) Bar graph illustrating the difference in duration for using hand counts vs. automated ImageJ processing. Mean times and standard error are shown. (B) Scatter plot of automated ImageJ counts against hand counts to illustrate their high agreement ($R^2 = 0.999$). (C) Percent error of the automated ImageJ method decreased with larger clutch sizes. (D) Efficiency improvement (hand count time/automated ImageJ count) dramatically increased with higher hand counts. The shaded area in the scatterplots (B, C, D) represents 95% confidence intervals.
References


Appendix 1. Step-by-step Instructions for ImageJ Egg Count Analysis

1. Place the light pad onto the studio copy stand and position the plate centred beneath the vertically-mounted camera’s frame (Fig. 2). Our camera was positioned 41 cm vertically from the sample with a focal length of 24 mm.

2. Spread the eggs onto the plate and prevent as much overlap as possible.

3. Set the light pad to max lumens and, with the flash off, take a photograph. External lamps or camera flashes are unnecessary because the light pad provides optimal contrast for processing (Fig. 3A).

4. Import the photo to ImageJ which is open-source freeware available from the National Institutes of Health (Rasband, 1997) at imagej.nih.gov/ij/download.html.

5. To make photo analysis faster, set shortcuts (Plugins → Shortcuts → Add shortcut…) for “Subtract Background,” “Colour Threshold” and “Make Inverse” (or see Appendix 2: Macros to assign these functions to F1, F2 and F3).

6. Subtract the background from the image (F1 or Process → Subtract Background). Check “light background” and the default rolling ball radius (50 px) seems sufficient in all cases.

7. Use “Colour Threshold” (F2 or Image → Adjust → Colour Threshold) to contrast the eggs from the background by setting “Threshold colour” to “B&W.” Slide the bottom brightness setting to reduce speckling but retain solid, dark eggs (Fig. 3B), and then close the dialog box.

8. Ensure colour is set to white (Ctrl + Shift + K or Image → Colour → Colour Picker), circle the eggs with the polygon or freehand selection tool, use the “Make Inverse” function (F3 or Edit → Selection → Make Inverse), and Fill (Ctrl + F or Edit → Fill) to delete any periphery noise or container outlines from the image. Removing periphery noise may not be necessary if your setup is clean (Fig. 3B), thereby eliminating this step.

9. Set the image to 8-bit (Image → Type → 8-bit) (the rest of these steps can be automated, see Appendix: Macros).

10. Apply the Despeckle process (Process → Noise → Despeckle) to remove visual noise – more than once may be necessary depending on the photo.

11. Use the watershed process (Process → Binary → Watershed) to segregate overlapping eggs or eggs from debris. Since amphibian embryos have a jelly coat, overlap is rarely an issue and does not lead to oversegmentation, which is common with watershed processing (Dougherty and Lotufo, 2003; Parker, 2011).

12. Finally, analyze particles (Analyze → Analyze Particles…) at “Size”: 100–550 px², “Circularity”: 0.50–1.00, “Show”: Overlay, and checkmark “Display results” and “Summarize.” “Size” will vary depending on egg size and your specific studio setup (e.g., camera lens, distance between camera and eggs, zoom level), but we found that these size parameters work very well for *Hyla* eggs and are probably useful for other, similarly-sized frogs as well.

Appendix 2. Macro Files

Those wishing to use macros need to save these commands as text files, install them (Plugins → Macros → Install) and run them (Plugins → Macros → Run). Macros can also be edited and recorded directly in ImageJ (Plugins → Macros → Record). Alternatively, these macros can be added as start-up macros (Plugins → Macros → Startup Macros), which loads them automatically each time ImageJ is opened.

Set_shortcuts.txt – Adds shortcuts to ImageJ

```plaintext
run("Add Shortcut... ",shortcut=F1 command=[Subtract Background...]);
run("Add Shortcut... ",shortcut=F2 command=[Color Threshold...]);
run("Add Shortcut... ",shortcut=F3 command=[Make Inverse]);
```

Count_Analysis.txt – Performs steps 9-12 in the software instructions. This macro can also be set as shortcut (e.g. run("Add Shortcut... ",shortcut=F4 command=Count_Analysis));).

```plaintext
run("8-bit");
run("Despeckle");
run("Watershed");
run("Analyze Particles... ",size=100-550 circularity=0.5-1.0 show=Overlay display clear summarize");
```

Accepted by Hinrich Kaiser